Khóa icon trên desktop windows 10

cứ mỗi lần Update drive là icon trên desktop nhảy loạn cào cào, lại phải ngồi sắp xếp lại
oogle mãi và kết quả ra cái trang này:

Locking/pinning Windows 10 desktop icons in place
nhưng có vẻ vô phương

Google tiếp thì như thế này

[Fix] Desktop Icons Position and Folder View Settings Problem in Windows 10

The problem occurs when Windows 10 doesn't save the position of icons on Desktop and the user-defined folder view settings.
If you put icons on Desktop in a certain order in Windows 10 and restart your computer, Windows 10 forgets the icons position and always puts the icons at the extreme left corner of the screen. Same thing happens with folder view settings. When a user changes a folder view to thumbnails, list, large icons, etc and closes Windows Explorer and then re-opens the same folder again, Windows 10 automatically changes the folder view to details.
Its a very irritating situation. Windows 10 never stores the Desktop icons placement order and folder view settings in Windows Explorer.
Sometimes this problem might be related to the popular antivirus company ESET products. Almost all users who are facing this problem in Windows 10, have reported that they were using ESET NOD32 antivirus or ESET Smart Security suite in their Windows 10 machines.
This problem occurs due to the faulty Cleaner module present in ESET products. Actually whenever ESET detects some malicious item in a computer, the older version of its Cleaner module changes an important key value in Registry during the cleaning process which causes this annoying problem in Windows 10. ESET has confirmed this issue and has released a testing update which fixes the Cleaner module functionality to solve this problem in Windows 10. But the update has not been released to stable channel. You'll need to change the update server to pre-release in ESET settings to download and install the new testing update. It may take some time for ESET to release the same update to stable channel.
In the meantime, if you are using Windows 10 and facing this problem, following steps will fix the problem (thanks to Arshia):
1. Press WIN+R keys together to launch RUN dialog box. Now type regedit in RUN and press Enter. It'll open Registry Editor.
2. Now go to following keys one by one: HKEY_CLASSES_ROOT\CLSID\{42aedc87-2188-41fd-b9a3-0c966feabec1}\InProcServer32

3. In right-side pane, check the value of (Default) string in both keys. It should be set to following: %SystemRoot%\system32\​
If the value is set to %SystemRoot%\SysWow64\shell32.dll or something else, you'll need to change the value of (Default) to %SystemRoot%\system32\


4. The above mentioned Registry keys are protected and to change the value of (Default), you'll need to first take ownership of InProcServer32 key in both locations.
You can take ownership of the keys with the help of following guide:
[Guide] How to Take Ownership (Permission) of a Registry Key in Windows?
After taking ownership, double-click on (Default) string and change its value to%SystemRoot%\system32\ in both keys.
Close Registry Editor and restart your computer to take effects. Now Windows 10 will always remember Desktop icons position and folder view settings.
NOTE: If you don't want to modify Registry yourself, you can download following ready-made Registry script to do the task automatically: Registry Script to Fix Desktop Icons Position Problem in Windows 10
After downloading the ZIP file, extract it and run the .REG file to fix the problem. But first you'll need to manually take ownership of the Registry key as mentioned in above tutorial. The Registry script can only change values in Registry Editor. It can't take ownership of keys.
PS: If you don't have ESET products installed in your computer but still facing this problem in Windows 10, check out following tutorials to fix the problem:
How to Fix Annoying Folder View Type Change Problem in Windows
[Solution] Windows Desktop doesn't Save User Customized Settings


Hình mất tiêu đâu rồi chủ thớt?
Học theo từ
Không giải quyết được nhóe

Simple Fix to Desktop Icons Rearranging

This worked for me (Windows 10, single screen)
Right click on the desktop
Choose Personalize, Themes, Desktop icon settings

I hope this works for you!

Recommendation to Windows Team - unchecked by default. From my research, I see many people have this problem and are spending a lot of time reloading Windows, editing their registry (!), and thinking unhappy thoughts. It took a lot of time to track down this obscure setting.